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1 Systematic Control Program Testing

This brief article describes how to test a control program systematically.
VISSIM has been chosen as the simulation tool. An intersection in Kun-
ming, China called "Xiao Ximen" has been chosen as the example.

2 Working with VISSIM

Ell.v:w., CAChina 200304 Kunming WISSIMY braffic actuated\Kunming. gpj
-/ Interseckion

Elf,': Ziao Kimen
[:l Reqgister: Contraller
[:l Reqister: W3-PLUS parameter sefking

[:| Register: Controller supply files
=1~ Register: ¥5-PLUIS test

EI[:l Reaqister: Simulation

— Define a VISSIM call in the VS-WorkSuite registers by defining
o The location of the VISSIM exe file and ("File")
o The location of the Xiao Ximen input file ("Parameter")
— Call VISSIM

— Set control type to VS-PLUS: Signal Control > Edit Signals > Edit >
Type list

+ VISSIM 3.60 - ciydl

Number: 25
More...
Name: [Xiao Ximen
Signal Groups...
Cyele Time: {127 s SigTimTbl.Cfg....

™ wariable

SCJ{Det.Rec....
Offset: 0 5

Import: ...
Type: =
SITRAFFIC -

0K | Cancel |

e

— Push the "More..." button and configure the following parameters:
o Program File — the VS-PLUS/SIM executable: vsp613.exe
o Import File — the VS-PLUS parameter file: xiaoximen.vce
Warning: the import file name must not contain spaces!
o Program No: 1 (as set in the program definition)
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7 ¥ISSIM 3.60 - )
File  Edit Network Edi

=FEIcE

imulation  Animation  Test

Number: |25
Name: [Xiao Ximen

Data for ¥5-PLUS

Cycle Time
Program File: | vsp613.exe
: ~Type
Witee Import File 1: | xiaoximen.vce “C
Type: I ImportFile 2: | 2 C PW1
oK. Program No.: fi] Reload Data
OK | Cancel |

— Run the simulation!

2.1 Signal and detector recording

A\

In order to obtain a diagram with the signal head and the detector states,
the following window has to be configured before simulation and opened

during or just before simulation.

— Configure the signal times table: Signal Control > Edit Signals > Edit >

SigTimTbl.Cfg

+" ¥ISSIM 3.60 - cz',chin.

File  Edit Metwork Editor  Signal Control  Options  Simulation  Animation Test

&

=i R 12

-~ Parameters

|

Number: 25
More...
MName: Xian Ximen
Signal Groups...
Cycle Time:  [127 s SigTimTbl.Cfg....
[~ wariable
SCJ/Det.Rec....
Offset: L] E
Import: ...
Type: V5-PLUS 'I
ISITHAFFIC hd
0K | Cancel | -

Signal Times Table Configuration

SCI:

25

Layout of Lines:
Line Type [Cat. No.]

e
2 Sig.Display 5G 2
3 Sig.Display SG 3 Type [Cal)
4 Sig.Display 5G 4
5 Sig.Display 5G &
6 Sig.Display SG b
7 Sig.Display SG 7
8 Sig.Display 5G 8
9 Sig.Display 5G 9

10 Sig.Display SG 10

11 State DET 20

12 End

p
Sig.Display 5G
State CP

State DET

Configuration File: | ><m.szp

Delete Line
Insert Line:

]v

— Configure the xxm.szp file by selecting the desired signal head and de-
tector information. The example shows all signal heads and detector on

channel 20.

— Make the list shown: Options > Evaluations > Windows > Signal Times

Table > Select All > Ok
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.- ¥ISSIM 3.60 - c\china\, 200304 kunming'vissim'traffic actuated'xxm.inp

File Edit Metwork Editor  Signal Control  Options — Simulation  Animation  Test

Analysis Online (Scre

SCJ{Det. Record...
Signal Times Table

Vehicle Info... I | p——
[~ Signal Changes
[~ Travel Times Deselect All

. Signal Groups
0K Cancel # Number
- . - ==  Name
i Detectors
* Number
= | € MName

Cancel

— Start the simulation

;i signal Settings SC1 25 =10 x|
S6 1 362 60 80 ———B55105 CE T - L
$¢ 2[———36 58§ —75 &0 FSss  ———s858|
s6 3[—4 16
6 d4[——21 31 5 30
56 5 60 70 95105 6480 —
S6 6 4755 ==l 5159 £
s6 7[—4& 16
56 8|—21 31 s 30
SG 9 60 70 95108 64 74
SG 10 60 70 95105 64 74

Det 20 | 1 ——4+—1—&l e H- HHH—— .

T T T T T T T T T T T T T T T T T T T
ol 10 20 30 40 50 60 70 80 90 100 110 120 10 20 30 40 50 60 70 80 -
4 »

2.2 State recording

In order to obtain a protocol with additional state information, the following
window has to be configured before simulation and opened during or just
before simulation.

— Configure the states table: Signal Control > Edit Signals > Edit >
SCJ/Det.Rec

.+ ¥IS5IM 3.60 - c:i,china’ 200304 kunming'vissim'traffic actuated\xxm.inp

File  Edit Metwork Editor  Signal Control  Options — Simulation  Animation  Test

Signal Controlled Junctions (SCJ)

x|

—Par

N
0
4
&
N
ﬁ "M scs: 25 Delete Column
i~

Cycl Layout of Columns: Insert Column:
Col. Type [Cat. No.]

1 Simul.second

Offs: 2 Cycle second
3 Hauptzeiger PE 1%

Type 4 Empty column
b Zustand ¥5 1* Anfo-Giiltig V5 1
6 Rahmen ¥5 1* Anforderungstyp V5 2

B 7 Sig.Display 5G 1* Cycle second 3

— 8 Empty column Empty column
9 Zustand ¥5 2% Frame
10 Rahmen V5 2% Griin als
11 Sig.Display SG 2 =| |GriinMax VS = =l

Column Header... I~ Shon Title
0K
Configuration File: | x<m.kfg
Recording File: soam.ldp Cancel

"N

Unfortunately, this panel is still mixed German — English. In order to know
the internal VS-PLUS states, the following variables have to be recorded:
« Simulation second

* Cycle second

!
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* Main pointer for priority element 1 (the only we are using right now) —
in German "Hauptzeiger PE1"
* For each signal head and traffic stream the following information (in
our case for the numbers 1 to 10):
o State of the traffic stream — in German "Zustand VS"
o Frame signal in the permissive period plan for the traffic stream —
in German "Rahmen VS"
o The signal display, i.e. the color shown by the signal head
* You can add empty columns in order to make the protocol better read-
able.

— Make the list shown: Options > Evaluations > Windows >
SCJ/Det.Record > Select All > Ok

- ¥155IM 3.60 - c:'chis

Animatiar

Select All |
Deselect All |

~Signal Groups —
& Number
 Name

Detectors
& Number
" Name

Cancel |

s5C1/Detector record 5C1 25 [ =]
5 5 5 5 4
i i i i i i i i i
=} g =] =} g =] =} g =]
I D D I D D I i D
5 CH i i i i i i i i i
i yva =] = = =] = = =] =] = —
m o i T el b T el b T bl 2Fp
u 1lmn SF SFL SF1 SF1 SFL SF1 SF1 SFL SF1 trl
1 e tr tra tra tra tra tra tra tra tra ans
P as aay aay aay aay aay aay aay aay Loy
3 3t T tm T T tm T =] tm T ee
e e r ee eed ees eed eed ees eed eed eed ]
o G G G G G G G G TTG
o o P TTS T TT TT T TT TT T TT 353
n nkE 333G 33 33 353 33 33 353 33 33 111
d d 1 111 ZEZ 3335 444 555 BGE 7T sta1=] 293 aoo

i 10 O+. 0+, 0#. 0#. 0+, 0+. 0#. 0#. O0+. O+.
z 20 O+. 0+, 0#. 0#. 0+, 0+. 0#. 0#. O0+. O+.
3 30 O+. 0+, 0#. O#. 0+, 0+. O#. 0#. O0+. O+.
4 4 3 E21+. 21+, 9FI Z1#. Z1l+. 21+, SHEI Z1#. 21+. 21+,
5 5 4 O+. 0+. 10#1 1#. 0+, O+. 10#I 14#. 0+. O+.
6 6 4 O+. 0+. 10#1 1#. 0+, O+. 10#I 14#. 0+. O+.
7074 O+. O+, 1041 1#. 0+. O+. 10+4I 1#. O0+. O+.
8 8 4 .. .. 1041 1#. .. o.. 10+I 14, o.. ..
9 94 .. .. 1241 1#. .. o.. 1241 14. o.. ..
10 10 4 .. .. 1241 1#. .. o.. 16+T 14. o.. .. LI

— The states are shown in columns. See the next section for an explica-
tion of internal VS-PLUS states.

— It is also possible to record this information into a file. Activate this log-
ging function by Make the list shown: Options > Evaluations > Files >
SCJ/Det.Record:

Systematic Control Program Testing with VS-PLUS 4



Dffline Analysis (File) x|

[~ Observer

™ Export Configuration

[~ Vehicle Record: Configuration Filter |
" Dist. of Green Times

[~ Node: Cnniiguratinnl Filter |

¥ SCJiDet. Record

" Signal Changes

[” Data Collection: Configuration

[~ Bus/Tram Wait. Time

™ Travel Time: Configuration

" Lane Change: Filter

[~ Queue Length: Configuration
[" Link Evaluations: Configuration
™ Delay: Configuration

[~ Vehicle Inputs
[~ Special Evaluations
" Paths [Dynamic Ass.]: Cnniiguratiunl Filter |

" Convergence -
0K I Cancel |

For a more comfortable view on this information, there is VS-VISTA with
the VS-PLUS Monitor: The use of VS-VISTA is not described in this docu-

ment.
[N R A

‘n |m ‘20 |3n 40 50 ‘sn |7n ‘en a0 100 110 120

NN RN Y AR i NUE i AR Y N i NS N AN e
1 [HEH | aEpn n anEnEn ERNRNNRERERRNENNENEY F ] a|minoca

T kil

_rnz |HH n L] n NEEEEERNEERENENENENNEREN EEEEREEE [ (12 min2 < G < max1
3 |HH NENRENNENNNNENEEE " " CITTT] 1 " E= ] &7 ] (0) Hocal

T i
_rha |HH EEEEERENEEER EEEEREEEER " T 1 'l =] =& |0Hocal
_pns | Il LTI NERENNNEENNENNENNNRNNRNEND AEERENRENE " ] 13| (o) Hocat
_ens | Il EERENEEEEEEER EEEEENRNNENEE F= 1 28 | 131 Green command ssued
_e7 JHH [ x . u B ] & ] (01 Hocal

a
_ene | n ERRRNRREEN 1 [T 1 1 E ] =] ke
EENEEE [ 1 1 T 1 [ |k
rss [ u T R EERERERER [T 1 [ e
|\|\‘HH\l\l‘\\\ll\l\‘\\\\\l\l‘\\\ll\l\‘\\\\\l\l‘\\\\l\l\l\\\\\l\l‘\\\\l\l\l\\\\\l\l‘\\\\l\l\l\\\\\l\l‘l\\\l\l\l\\
‘n |m ‘zn |3u ‘an |5I] ‘sn |7u ‘an |su ‘mn “HEI ‘un
[ (= = &
start Pauss Stop Cancel

[

2.3 Internal VS-PLUS variables
* General variable
o Active flag
* Detector variable
o Detector waiting time
* Phase variables
o State
o Waiting time
o Periority class
o Periority level
o Priority value
» Special variables in connection with public transit
o PT priority

o dT frame

o Remaining travel time
o Zone

o Status

* Picture variable
o Main pointer

Systematic Control Program Testing with VS-PLUS 5



2.3.1 Active flag

The active identifier indicates the status concerning the idle picture for the
three partial intersections.

0 No idle picture possible, there is still traffic.

1 The idle picture can be activated.

2 The idle picture is active.

2.3.2 Detector waiting time
As soon as a detector has a call, its waiting time is started.

2.3.3 Phase variables

2.3.3.1 Status

The status is one of the most important variables of the VS PLUS control.
This variable defines, how the phase may be processed. The value of the
status can be divided into two ranges:
* The phase has red:
The phase is inactive.
The phase has the intervention level 1.
The phase has the intervention level 2.
The phase has the intervention level 3.
The phase has the intervention level 4.
The phase has the intervention level 5.
The phase can be started.
The phase was set to green.
* The phase has green:
10 The phase did not yet reach the green time tgmin1.
11 The phase exceeded the green time tgmin1.
12 The phase exceeded the green time tgmin2.
13 The phase exceeded the green time tgmax1.
14 The phase exceeded the green time tgmax2 and there is still
traffic.
15 The phase does not have traffic, can be further extended ac-
cording to extension flag if necessary.
16  The phase does not have traffic, cannot be further extended.
19  Special red command for the phase.
20 The phase can be set to red.
21 The phase was set to red.

2.3.3.2 Waiting time
The waiting time is started for each phase after a call.

oo hwWN-=-0

2.3.3.3 Priority class

Each phase in a main series is associated with a priority class.
0 The phase is in no priority class.
1 The phase is in priority class 1.
2 The phase is in priority class 2.
3 The phase is in priority class 3.

2.3.3.4  Priority level

Each phase is in the priority level 1 by default. Once exceeding the maxi-
mum waiting time he gets into the level 2.

Systematic Control Program Testing with VS-PLUS 6



2.3.3.5 Priority value

The priority value (PV) is set for each phase, which is to be switched to

green. It consists of three parts:

* The basic priority depends on the priority element in which the phase is
processed.

* PV = (Maximum number of priority elements - Position in the process-
ing sequence) * 100

* Added is its rank as a minor phase in the desired picture.

* PV =PV + Maximum number of minor phases - Current rank + 1

* In addition the value can be increased using the parameter priority
value.

* PV =PV + Priority value * 1000

2.3.4 PT variables

2.3.4.1 PT priority

The PT priority indicates whether a PT phase can be served after the proc-
essing of the module PT prioritization

0 Switching not permitted

1 Switching permitted

2.3.4.2 dT Frame

The variable dT Frame indicates the temporal difference between the ex-
pected arrival second and the beginning of frame signal.

2.3.4.3 Remaining travel time

The variable remaining travel time indicates the time a PT vehicle will still
travel up to the stop bar. If the time is negative it corresponds to the waiting
time at the stop bar.

2.3.4.4 Zone

The zone indicates the type of function a PT phase is currently exercising.
No call range available.

Hold time exceeded, call range exceeded.

Only ADVANCE.

Always ADVANCE if possible, no switch on call possible.
ADVANCE if possible, otherwise call.

Only BLOCKING.

Always BLOCKING if possible, no switch on call possible.
BLOCKING if possible, otherwise call.

Register

2.3.4.5 Status
The status describes, how the PT affects a phase at the current time.
0 no influence

o~NOoOOONOAhWN=-0

2/31/4 may advance
5/617 will be blocked

2.3.5 Main pointer

The variable main pointer indicates the current main phase for each priority
element.

Systematic Control Program Testing with VS-PLUS 7



3 Systematic control program testing

It is important that any control program is tested thoroughly with a simulator
before being deployed to the intersection controller.

The tools we use are VISSIM and the previously introduced diagrams, to-
gether with the VS-WorkSuite. While optimizing and refining the parameter
sets, the new parameters can immediately be tested after exporting them
from VS-WorkSuite, by restarting a VISSIM simulation.

The systematic approach is as follows:

3.1 No traffic

Test the program without traffic.

Test the program with continuous occupation of all detectors.

Test the program with simulated traffic.

In the case of fully traffic-dependent control, especially without a per-
missive period plan, manual clicking on single detectors might be
checked for correct functioning.

There are also hybrid testing scenarios where, especially for public
transport functions, pre-recorded detector macros are played. We will
not treat this feature here.

— Open a signal and detector recording window.
— Go to VISSIM test mode: Test > Continuous

— VISSIM goes to test mode showing all detectors and signal head

states. Do not click on the detectors.

{“signal Settings SCJ 25

T T T T T T T T T T T T T T T T T
50 (1] 70 80 90 100 110 120 10 20 30 40 50 60 70 a0 90 100 110 120

—

Look at the recording window. There should be a steady state signal
plan serving all phases in a reasonable manner.

Systematic Control Program Testing with VS-PLUS 8




3.2 Continuous occupation
— Open a signal and detector recording window.
— Go to VISSIM test mode: Test > Single step

— Double-click on all detectors in order to make them continuously occu-
pied (light blue). Single clicking generates a detector impulse (blue) that
can be used for individual detector testing.

— Start the testing either step by step or continuously using the normal
VISSIM buttons.

s signal Settings SCJ 25

T T T T
50 60 70 a0

T T T T T T T T
90 100 110 120 10 20 30 40 50 60 T0 a0 90 100 110 120

I+

— Look at the recording window. Again, there should be a steady state
signal plan serving all phases in a manner that corresponds to the traf-
fic flows under full load.

3.3 Simulated traffic
— Open a signal and detector recording window.
— Go to VISSIM simulation mode: Simulation > Continuous

— Look at the recording window. There will be no steady state. Check if
the resulting signal sequences correspond to what your intention was.

— Sometimes you might be surprised because VS-PLUS generates signal
sequences you never thought about before. Check if you want to ac-
cept them. If not, find the parameters to inhibit certain signal sequences
and modify them.

Systematic Control Program Testing with VS-PLUS 9




=
s6 1|46 66 ——91 108 46 71 ——88 1089 ———
S6 2486 . 88 46 81
s6 3 113 11 plalc: |
S8 4 16 41
SE 5 91 108 86 103
SE 6 71 8s AL
s6 7 113 11 114
S6 8 16 41
s6 9 91101 56 96
S6 10 91101 86 96
Det 2UF—I—I+7I+~H - H— FHHHHH
T T T T T T T T T T T T T T T T T T T T
_I | 50 60 70 80 a0 100 110 120 10 20 30 40 50 60 70 80 a0 100 110 120 I I
4 13

— Signal sequence: 1|12 — 2|6 — 1|5|9|10 — 3|7 — 4|8
Normal signal sequence as defined in the static signal plan. Timing var-
ies a bit between the two following cycles.

, signal Settings SC1 25

56 HE ———63 G0 54 64 55 108
56 245 84 ————85 120 54 80
56 3 125 13 113
56 4 24 am
S6 5 85 108
56 6 55 64 85 120 69 80
s6 7 125 19 113
S8 8 24 48
6 9 63 79 85 35
56 10 63 79 55 95
Det 20F—-I- FH--- H F HHHH
T T T T T T T T T T T T T T T T T T T T
| | 50 60 70 B0 90 100 110 120 10 20 30 40 50 60 70 80 90 100 110 120 n
4 »

— Signal sequence: 1|2 — 2|6 — 1|5|9|10 — 2|6 — 3|7 — 4|8
There has been an extra 2|6 phase due to heavy left turn load on the
west access.

i signal Settings 5C1 25

|

89 99

2
3
1

56 §5|—————64 &0
6|——5153
7
8

56 9|——F4 74 ———— 105118
———64 74 10515 97 111 ———
pet 20|HH HH——HHEEE- - H- HHEEEEEEE— - 1 -+ HH-HHHHHE—

T T T T T T T T T T T T T T T T T T T T
50 60 70 80 90 100 110 120 10 20 30 40 50 60 T0 80 90 100 110 120

| | +]

— Signal sequence: 1|12 — 2|6 — 1[5|9]10 = 2|6 — 19|10 — 3|7 — 4|8
There has been an extra 2|6 phase and an extra bus phase, i.e. the
buses have been served twice in a cycle.

=Y
S6 1=—_ 55 7z ——87 107 ——m—
56 2 —84 118 SER=
S6 3 124 20 112
56 4 25 &80
S¢ 5S————76 89 87 107 ——m
S6 6 R 103 119 EE
86 7 124 20 112
S6 8 25 50
S8 9 —————76 &8 87 97
86 10— 78 &8 87 97
pet 20 HHH+HH-HH—HHEEEEE 1 - H- - | - H ]| B - | - -
T T T T T T T T T T T T T T T T T T T T
_I 50 60 70 80 90 100 110 120 10 20 30 40 50 60 70 a0 90 100 110 120 I I
4 »

— Signal sequence: 1|2 — 2|6 — 1|5[9|10 = 1|2 — 2|6 — 3|7 — 4|8
There has been an extra 1|2 phase, followed by an extra 2|6 phase in
order to serve phase 2 more, even though phase 1 was running out of
traffic.

Systematic Control Program Testing with VS-PLUS 10




— Don't forget to check optically the resulting waiting queues and whether
they do not exceed the maximum length you are willing to accept.

File  Edit [etwork Editor  Signal Control  Options — Simulation  &nimation Test

— This screen dump shows VISSIM after 40 minutes of simulated time
during rush hour. The queues look all very satisfying, so this VS-PLUS
parameter set is ready to be deployed!

Systematic Control Program Testing with VS-PLUS 11
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